import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[A-Za-z]*[A-Z][A-Za-z]+\\b";
final String string = "Buveinės adresas: Konstitucijos pr. 20A, 03502 Vilnius\n"
+ "Telefonai:\n"
+ "1884 arba +370 5 268 4444 (Privatiems klientams)\n"
+ "1633 arba +370 5 268 4422 (Verslo klientams)\n"
+ "Faksas: (8 5) 258 2700\n"
+ "El. paštas: info@swedbank.lt\n"
+ "Įmonės kodas: 112029651\n"
+ "PVM mokėtojo kodas: LT120296515\n"
+ "Banko sąskaita: LT55 7300 0100 0000 0036\n"
+ "Banko kodas: 73000\n"
+ "SWIFT kodas: HABALT22";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}