# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b[A-Za-z]*[A-Z][A-Za-z]+\b"
test_str = ("Buveinės adresas: Konstitucijos pr. 20A, 03502 Vilnius\n"
"Telefonai:\n"
"1884 arba +370 5 268 4444 (Privatiems klientams)\n"
"1633 arba +370 5 268 4422 (Verslo klientams)\n"
"Faksas: (8 5) 258 2700\n"
"El. paštas: info@swedbank.lt\n"
"Įmonės kodas: 112029651\n"
"PVM mokėtojo kodas: LT120296515\n"
"Banko sąskaita: LT55 7300 0100 0000 0036\n"
"Banko kodas: 73000\n"
"SWIFT kodas: HABALT22")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.