import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)(?<Changed>^[^-]*$)";
final String string = "Changed Attributes:\n"
+ " SAM Account Name: -\n"
+ " Display Name: -\n"
+ " User Principal Name: -\n"
+ " Home Directory: -\n"
+ " Home Drive: -\n"
+ " Script Path: -\n"
+ " Profile Path: -\n"
+ " User Workstations: -\n"
+ " Password Last Set: -\n"
+ " Account Expires: -\n"
+ " Primary Group ID: -\n"
+ " AllowedToDelegateTo: -\n"
+ " Old UAC Value: 0x10\n"
+ " New UAC Value: 0x1DA11\n"
+ " User Account Control: \n"
+ " Account Disabled\n"
+ " 'Don't Expire Password' - Enabled\n"
+ " 'Encrypted Text Password Allowed' - Enabled\n"
+ " 'Smartcard Required' - Enabled\n"
+ " 'Not Delegated' - Enabled\n"
+ " 'Use DES Key Only' - Enabled\n"
+ " 'Don't Require Preauth' - Enabled\n"
+ " User Parameters: -\n"
+ " SID History: -\n"
+ " Logon Hours:";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}