# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?m)(?<Changed>^[^-]*$)"
test_str = ("Changed Attributes:\n"
" SAM Account Name: -\n"
" Display Name: -\n"
" User Principal Name: -\n"
" Home Directory: -\n"
" Home Drive: -\n"
" Script Path: -\n"
" Profile Path: -\n"
" User Workstations: -\n"
" Password Last Set: -\n"
" Account Expires: -\n"
" Primary Group ID: -\n"
" AllowedToDelegateTo: -\n"
" Old UAC Value: 0x10\n"
" New UAC Value: 0x1DA11\n"
" User Account Control: \n"
" Account Disabled\n"
" 'Don't Expire Password' - Enabled\n"
" 'Encrypted Text Password Allowed' - Enabled\n"
" 'Smartcard Required' - Enabled\n"
" 'Not Delegated' - Enabled\n"
" 'Use DES Key Only' - Enabled\n"
" 'Don't Require Preauth' - Enabled\n"
" User Parameters: -\n"
" SID History: -\n"
" Logon Hours:")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.