import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=sda1)\\s+(?|(\\d+.?\\d+)[G,M.L,%]?)\\s+(?|(\\d+.?\\d+)[G,M.L,%]?)\\s+(?|(\\d+.?\\d+)[G,M.L,%]?)\\s+(\\d+)%";
final String string = "Filesystem Size Used Avail Use% Mounted on\n"
+ "udev 3.8G 0 3.8G 0% /dev\n"
+ "tmpfs 806M 5.3M 800M 1% /run\n"
+ "/dev/mmcblk0p2 235G 59G 164G 27% /\n"
+ "tmpfs 4.0G 0 4.0G 0% /dev/shm\n"
+ "tmpfs 5.0M 48K 5.0M 1% /run/lock\n"
+ "/dev/mmcblk0p1 510M 63M 448M 13% /boot/firmware\n"
+ "/dev/sda1 137.8G 299.88G 127G 3% /media/usbplatte\n"
+ "tmpfs 806M 0 806M 0% /run/user/1000\n\n"
+ "/dev/sda1 139752 2662 129920 3% /media/usbplatte\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}