const regex = /(?<=sda1)\s+(?|(\d+.?\d+)[G,M.L,%]?)\s+(?|(\d+.?\d+)[G,M.L,%]?)\s+(?|(\d+.?\d+)[G,M.L,%]?)\s+(\d+)%/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=sda1)\\s+(?|(\\d+.?\\d+)[G,M.L,%]?)\\s+(?|(\\d+.?\\d+)[G,M.L,%]?)\\s+(?|(\\d+.?\\d+)[G,M.L,%]?)\\s+(\\d+)%', 'gm')
const str = `Filesystem Size Used Avail Use% Mounted on
udev 3.8G 0 3.8G 0% /dev
tmpfs 806M 5.3M 800M 1% /run
/dev/mmcblk0p2 235G 59G 164G 27% /
tmpfs 4.0G 0 4.0G 0% /dev/shm
tmpfs 5.0M 48K 5.0M 1% /run/lock
/dev/mmcblk0p1 510M 63M 448M 13% /boot/firmware
/dev/sda1 137.8G 299.88G 127G 3% /media/usbplatte
tmpfs 806M 0 806M 0% /run/user/1000
/dev/sda1 139752 2662 129920 3% /media/usbplatte
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}