using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(FO|FQ|FRY|HW)(?<!\(\1(?=\)))";
string input = @"(FO
FO)
FO
(FO)
(FQ
FQ)
FO
(FQ)
(FRY
FRY)
FRY
(FRY)
(HW
HW)
HW
(HW)
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}