const regex = /(FO|FQ|FRY|HW)(?<!\(\1(?=\)))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(FO|FQ|FRY|HW)(?<!\\(\\1(?=\\)))', 'gm')
const str = `(FO
FO)
FO
(FO)
(FQ
FQ)
FO
(FQ)
(FRY
FRY)
FRY
(FRY)
(HW
HW)
HW
(HW)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}