using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"IP\(([^)]*\..+)\):Y\(([^)]*\..+)\)";
string input = @"show run IP(k1) new Y(y1) add IP(dev.maintserial):Y(dev.maintkeys)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}