re = /IP\(([^)]*\..+)\):Y\(([^)]*\..+)\)/m
str = 'show run IP(k1) new Y(y1) add IP(dev.maintserial):Y(dev.maintkeys)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end