$re = '~(?<!https:|http:)//.*?//~m';
$str = '//Some text//
http://SomeURL//foo
https://SomeURL//bar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);