re = /(?<!https:|http:)\/\/.*?\/\//m
str = '//Some text//
http://SomeURL//foo
https://SomeURL//bar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end