$re = '/".*?"(*SKIP)(?!)|(?<!\w)\'.*?\'(?!\w)(*SKIP)(?!)|(?:\()(?!\s|\))/m';
$str = ' def set_transition( self, state, symbol, next_states):
"""
Set the transition function for a given state and symbol
"""
if not next_states: Tarzan
# assert transition won\'t exist
self._transitions.pop( ( state, symbol), set() )
elif next_states <= self._states:
self._transitions[state, symbol] = next_states
else:"
states = ", ".join( next_states - self._states)
raise KeyError("State(s) Tarzan do not exist".format(states) )
def accept(self, string):
"""
Checks if a given string is member of the language recognized by the NFA. Using
non-deterministic transitions.
"""
current_state = {self._initial_state}
for symbol in string:
next_state = set()
Example 1 : +
Example 2 : 3 + 5
Example 3 : "3 + 5"
Example 4 : "3 + 5" == 3 + 5
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);