# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\".*?\"(*SKIP)(?!)|(?<!\w)'.*?'(?!\w)(*SKIP)(?!)|(?:\()(?!\s|\))"
test_str = (" def set_transition( self, state, symbol, next_states):\n"
" \"\"\"\n"
" Set the transition function for a given state and symbol\n"
" \"\"\"\n\n"
" if not next_states: Tarzan\n"
" # assert transition won't exist\n"
" self._transitions.pop( ( state, symbol), set() )\n\n"
" elif next_states <= self._states:\n"
" self._transitions[state, symbol] = next_states\n\n"
" else:\"\n"
" states = \", \".join( next_states - self._states)\n"
" raise KeyError(\"State(s) Tarzan do not exist\".format(states) )\n\n"
" def accept(self, string):\n"
" \"\"\"\n"
" Checks if a given string is member of the language recognized by the NFA. Using\n"
" non-deterministic transitions.\n"
" \"\"\"\n"
" current_state = {self._initial_state}\n\n"
" for symbol in string:\n"
" next_state = set()\n\n"
"Example 1 : +\n"
"Example 2 : 3 + 5\n"
"Example 3 : \"3 + 5\"\n"
"Example 4 : \"3 + 5\" == 3 + 5\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.