re = /.*\bChia\b.*/i
str = 'Chia seeds
i like to eat Chia seeds
i like to eat chia seeds
NoChia
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end