re = /^(\d+\s?(years|year|months|month|weeks|week|days|day|hours|hour|minutes|minute|min|mins|seconds|second|sec|secs|y|M|w|d|h|m|s)\s?)+$/i
str = '1y 5M 3w 5d 23h 59m 50s'
# Print the match result
str.match(re) do |match|
puts match.to_s
end