// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)^(\d+\s?(years|year|months|month|weeks|week|days|day|hours|hour|minutes|minute|min|mins|seconds|second|sec|secs|y|M|w|d|h|m|s)\s?)+$").unwrap();
let string = "1y 5M 3w 5d 23h 59m 50s";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}