$re = '/^[^;]+;[^;]+;;[^;]+;[^;]+$/';
$str = 'test;deVolgendeWaardeIsLeeg;;1234AB;hetDakjeTussenDeHaakjesBetekentAllesBehalveEenPuntKommaEnDePlusAchterDeHaakjesBetekentDatDezeWaarden1ofMeerMoetVoorkomen';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);