re = /^[^;]+;[^;]+;;[^;]+;[^;]+$/
str = 'test;deVolgendeWaardeIsLeeg;;1234AB;hetDakjeTussenDeHaakjesBetekentAllesBehalveEenPuntKommaEnDePlusAchterDeHaakjesBetekentDatDezeWaarden1ofMeerMoetVoorkomen'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end