#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\$\w+(?:\((?<arg>(?R)|(?:\"[^\"]*\")|(?:[^\$\"\&\s\(\)][^\s\(\)]*))(?:(?:\+| )(?&arg))*\))?)|(?<var>\&\w+)"
Local $sString = "$test($test(test &var1 $var2) $test(jean) jean) # should full-match" & @CRLF & _
"$test($test(test $var1 $var2) $test(foo) bar) # should not full-match" & @CRLF & _
"$test("&test") # should not full-match" & @CRLF & _
"$test("foo&test") # should not full-match" & @CRLF & _
"$test("&test" &test) # should full-match" & @CRLF & _
"&test # should full-match" & @CRLF & _
"$test(" &test") # should not full-match" & @CRLF & _
"$test # should not full-match" & @CRLF & _
"&test(foo) # should not full-match" & @CRLF & _
"&test(&foo $bar()) # should not full-match" & @CRLF & _
"$test((&test)) # should not full-match" & @CRLF & _
"$foo(bar(&baz)) # should not full match" & @CRLF & _
"$test(&test &test) # should not full match" & @CRLF & _
"$test( &test) # should not full match" & @CRLF & _
"$test(&test ) # should not full match"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")