# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:\$\w+(?:\((?<arg>(?R)|(?:\"[^\"]*\")|(?:[^\$\"\&\s\(\)][^\s\(\)]*))(?:(?:\+| )(?&arg))*\))?)|(?<var>\&\w+)"
test_str = ("$test($test(test &var1 $var2) $test(jean) jean) # should full-match\n"
"$test($test(test $var1 $var2) $test(foo) bar) # should not full-match\n"
"$test(\"&test\") # should not full-match\n"
"$test(\"foo&test\") # should not full-match\n"
"$test(\"&test\" &test) # should full-match\n"
"&test # should full-match\n"
"$test(\" &test\") # should not full-match\n"
"$test # should not full-match\n"
"&test(foo) # should not full-match\n"
"&test(&foo $bar()) # should not full-match\n"
"$test((&test)) # should not full-match\n"
"$foo(bar(&baz)) # should not full match\n"
"$test(&test &test) # should not full match\n"
"$test( &test) # should not full match\n"
"$test(&test ) # should not full match")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.