package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)\/\*\*.*?\*\/\s*function(*SKIP)(*FAIL)|\/\*\*.*?\*\/\s*`)
var str = `/**
*
*
*
*
*/
function
/**
*
*
*
*
*/
/**
*
*
*
*
*/
function
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}