re = /\/\*\*.*?\*\/\s*function(*SKIP)(*FAIL)|\/\*\*.*?\*\/\s*/
str = '/**
*
*
*
*
*/
function
/**
*
*
*
*
*/
/**
*
*
*
*
*/
function
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end