const regex = /<div class="panel-body">([^]*?)(<\/div>|$)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<div class="panel-body">([^]*?)(<\\\/div>|$)', 'gi')
const str = `<div class="panel-body">
Line 1
Line 2
Line 3
</div>
Don't match after closing \`div\`...but match this and below in case closing \`div\` is removed.
Line below 1
Line below 2
Line below 3
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}