re = /departments":\["(.+?)"/
str = '1.)"departments":["Processed & Soft Cheese1"],'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end