$re = '/(?<type>build)(?<scope>(?:\([^()\r\n]*\)|\())?(?<breaking>!)?(?<separator>:)? ?(?<subject>.+$)?/m';
$str = 'build(one)
build(two)!
build(three)!:test
build(example:module)!: test subjectxxx xczxczxczx
build: test
build(<> : dda!sd): test
build(:
build';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);