re = /(?<type>build)(?<scope>(?:\([^()\r\n]*\)|\())?(?<breaking>!)?(?<separator>:)? ?(?<subject>.+$)?/m
str = 'build(one)
build(two)!
build(three)!:test
build(example:module)!: test subjectxxx xczxczxczx
build: test
build(<> : dda!sd): test
build(:
build'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end