// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(..).(..).").unwrap();
let string = "aabbсс";
let substitution = "$14$2X";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}