$re = '~(?:<(?:(?:(?:(script|style|object|embed|applet|noframes|noscript|noembed)(?:\s+(?>"[\S\s]*?"|\'[\S\s]*?\'|(?:(?!/>)[^>])?)+)?\s*>)[\S\s]*?</\1\s*(?=>))|(?:/?[\w:]+\s*/?)|(?:[\w:]+\s+(?:"[\S\s]*?"|\'[\S\s]*?\'|[^>]?)+\s*/?)|\?[\S\s]*?\?|(?:!(?:(?:DOCTYPE[\S\s]*?)|(?:\[CDATA\[[\S\s]*?\]\])|(?:--[\S\s]*?--)|(?:ATTLIST[\S\s]*?)|(?:ENTITY[\S\s]*?)|(?:ELEMENT[\S\s]*?))))>(*SKIP)(*FAIL)|[<>"&\'])~';
$str = 'Lorem ipsum dolor sit amet, "consetetur" sadipscing elitr.
<ul>
<li>At vero eos et accusam et justo</li
<li>Stet clita "kasd" gubergren</li>
</ul>
<a href="https://www.google.com/" target="_blank">https://www.google.com/</a>
"At vero eos et accusam et justo duo dolores et ea rebum. , no sea takimata sanctus est Lorem ipsum dolor sit amet."';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);