$re = '/\b(\d+)x? (\w+(?: \w+)*)(?: \(([^()]+)\) (\d+))?\b/m';
$str = '1 Ripe Avocado
1x Ripe Avocado
1 Ripe Avocado (lrg) 123
1x Ripe Avocado (lrg) 123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);