// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(\d+)x? (\w+(?: \w+)*)(?: \(([^()]+)\) (\d+))?\b").unwrap();
let string = "1 Ripe Avocado
1x Ripe Avocado
1 Ripe Avocado (lrg) 123
1x Ripe Avocado (lrg) 123";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}