package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<day>\d+)\/(?<month>\d+)\/(?<year>\d+)`)
var str = `16/04/1987
1/1/2021
31/1/2011`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}