re = /(?=\[\[Image:)(\[(?:[^][]|(?1))*])(?<=]])/m
str = '[[Image:Justus Sustermans - Portrait of Galileo Galilei (Uffizi).jpg|left|thumb|upright|[[Galileo]] is often referred to as the Father of [[modern astronomy]], portrait by [[Justus Sustermans]]]]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end