using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*?)\\(.*?)\s(.*)\\(.*?)\\(.*)";
string input = @"Projects\UP/PS (21063)\2789 (spain) / Ref/15\Email";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}