re = /(.*?)\\(.*?)\s(.*)\\(.*?)\\(.*)/m
str = 'Projects\\UP/PS (21063)\\2789 (spain) / Ref/15\\Email'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end