$re = '/^(?!.*@.*@|.*,.*,|.*\..*\.)[A-Za-z0-9 @,.-]{3,}$/m';
$str = 'em@il, test.
email, test
em@il, test,
em@ail, test. @bc.
eee
e@a
e@b.c';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);