re = /^(?!.*@.*@|.*,.*,|.*\..*\.)[A-Za-z0-9 @,.-]{3,}$/m
str = 'em@il, test.
email, test
em@il, test,
em@ail, test. @bc.
eee
e@a
e@b.c'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end