using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"t \(\d+\)";
string input = @"t (3)
t (1)
t (99)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}