$re = '/t \(\d+\)/m';
$str = 't (3)
t (1)
t (99)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);