import re
regex = re.compile(r"(?:'|\")(.*(?:'|\").*(?:'|\"))(?:'|\")")
test_str = ("The sentence is 'He said \"Hello there\"'\n"
"The sentence is \"He said 'Hello there'\"\n"
"The sentence is 'He said \"Goodbye\"\n"
"The sentence is \"abc 123' and 'He said \"Goodbye\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")