re = /(?:'|")(.*(?:'|").*(?:'|"))(?:'|")/
str = 'The sentence is \'He said "Hello there"\'
The sentence is "He said \'Hello there\'"
The sentence is \'He said "Goodbye"
The sentence is "abc 123\' and \'He said "Goodbye"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end