$re = '/[0-9]*\sFOR\s£[0-9]*/';
$str = 'N1 LTPO BABY FOOD 6 FOR £5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);