use strict;
my $str = '// SHOULD MATCH
foo(() ((hello) world))
bar (hello world!)
baz(ddd(()))
bazbaz(dsadsa")" dsada)
////multiple functions in a row
foo(() ((hello) world)); bar(gffjdk)
h(dsaqwd);h(dsaqwd)
h(dsaqwd); h(dsaqwd);
h(dsaqwd)
h
(dsaqwd)
////String escaping mess
f("a;");g("b");
f("a;\\"");g("b");
bazbaz(") " d " ;" );
f("a;\\");");g("\\"b;");
bazbaz(dsadsa")" d(()(das))das)das)ds)a(d(sa(d)()()sada); ;; d(ssss)
f("a"){""};g("\\"b;");
bar(a =") ", b = " );")
//NOT
()
((((
)))
';
my $regex = qr/(?<=[\w \n]\()(?:[^;\n"]|(?:"(?:[^"]|\\")*?(?<!\\)"))*(?=\))/mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}