import Foundation
let pattern = #"(?<=[\w \n]\()(?:[^;\n"]|(?:"(?:[^"]|\\")*?(?<!\\)"))*(?=\))"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
// SHOULD MATCH
foo(() ((hello) world))
bar (hello world!)
baz(ddd(()))
bazbaz(dsadsa")" dsada)
////multiple functions in a row
foo(() ((hello) world)); bar(gffjdk)
h(dsaqwd);h(dsaqwd)
h(dsaqwd); h(dsaqwd);
h(dsaqwd)
h
(dsaqwd)
////String escaping mess
f("a;");g("b");
f("a;\"");g("b");
bazbaz(") " d " ;" );
f("a;\");");g("\"b;");
bazbaz(dsadsa")" d(()(das))das)das)ds)a(d(sa(d)()()sada); ;; d(ssss)
f("a"){""};g("\"b;");
bar(a =") ", b = " );")
//NOT
()
((((
)))
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)