package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d)\d+(\d{4})$`)
var str = `123456789
16389047271939
62518939`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}