$re = '/^(\d)\d+(\d{4})$/m';
$str = '123456789
16389047271939
62518939';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);