import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:https?:\\/\\/)((?:www\\.)|(?:m\\.))?soundcloud\\.com\\/[a-z0-9](?!.*?(-|_){2})[\\w-]{1,23}[a-z0-9](?:\\/.+)?$";
final String string = "Use only numbers, lowercase letters, underscores, or hyphens.\n"
+ "Profile URLs must not start or end with an underscore or hyphen.\n"
+ "Profile URLs must not have two consecutive underscores or hyphens.\n"
+ "Profile URLs must be between 3 and 25 characters.\n\n"
+ "http://www.soundcloud.com/fo\n"
+ "http://www.soundcloud.com/foo\n"
+ "https://m.soundcloud.com/abcd123\n"
+ "https://soundcloud.com/abcd123\n"
+ "https://soundcloud.com/\n"
+ "https://m.soundcloud.com/abcd123_l\n"
+ "https://soundcloud.com/abcd123-l\n"
+ "http://www.soundcloud.com/-abcd123\n"
+ "http://www.soundcloud.com/_abcd123\n"
+ "https://m.soundcloud.com/abcd123-_l\n"
+ "https://m.soundcloud.com/abcd123--l\n"
+ "https://m.soundcloud.com/1234567890123456789012345\n"
+ "https://m.soundcloud.com/12345678901234567890123456\n"
+ "https://m.soundcloud.com/1234567890123456789012345/fooo12;lkflkjlfjkljskljflks/\n"
+ "https://m.soundcloud.com/12345678901234567890123456/fooo\n"
+ "http://www.m.soundcloud.com/abcdef";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}