import re
regex = re.compile(r"^(?:https?:\/\/)((?:www\.)|(?:m\.))?soundcloud\.com\/[a-z0-9](?!.*?(-|_){2})[\w-]{1,23}[a-z0-9](?:\/.+)?$", flags=re.MULTILINE)
test_str = ("Use only numbers, lowercase letters, underscores, or hyphens.\n"
"Profile URLs must not start or end with an underscore or hyphen.\n"
"Profile URLs must not have two consecutive underscores or hyphens.\n"
"Profile URLs must be between 3 and 25 characters.\n\n"
"http://www.soundcloud.com/fo\n"
"http://www.soundcloud.com/foo\n"
"https://m.soundcloud.com/abcd123\n"
"https://soundcloud.com/abcd123\n"
"https://soundcloud.com/\n"
"https://m.soundcloud.com/abcd123_l\n"
"https://soundcloud.com/abcd123-l\n"
"http://www.soundcloud.com/-abcd123\n"
"http://www.soundcloud.com/_abcd123\n"
"https://m.soundcloud.com/abcd123-_l\n"
"https://m.soundcloud.com/abcd123--l\n"
"https://m.soundcloud.com/1234567890123456789012345\n"
"https://m.soundcloud.com/12345678901234567890123456\n"
"https://m.soundcloud.com/1234567890123456789012345/fooo12;lkflkjlfjkljskljflks/\n"
"https://m.soundcloud.com/12345678901234567890123456/fooo\n"
"http://www.m.soundcloud.com/abcdef")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")