$re = '/[0-9]+(?:\.[0-9]+)?/m';
$str = '.....
50
50.12
1.1234
5894023253.1341223';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);