const regex = /(\d) +(?=%)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d) +(?=%)', 'g')
const str = `test 12 %
test 1.2 %
test 1,2 % 2.5 %
% test 1,2 % 2.5 % something`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);